24 de Febrero, 2006

Vulnerabilidad en The Bat! 3.60.07 permite ejecutar código arbitrario

Por marcelo-ar - 24 de Febrero, 2006, 5:43, Categoría: General

NSA Group (www.nsag.org) reporta una vulnerabilidad de gravedad crítica en The Bat!

La vulnerabilidad existe debido a un chequeo insuficiente del tamaño del buffer de una variable en la cual se copian datos del campo "Subject" (asunto del mensaje).

Al recibir un mensaje especialmente alterado cuyo campo "Subject" contenga 4038 bytes, se generará un desbordamiento de buffer que posibilitará al atacante malicioso la ejecución de código arbitrario.

Tiempos de divulgación:
19/11/2005 - Notificación al fabricante.
12/12/2005 - Respuesta del fabricante.
22/02/2006 - Publicación de los detalles de la vulnerabilidad.

Solución:
Actualizar a la versión más reciente de The Bat!
http://thebat.net/en/products/thebat/download.php

Ref.:
Bugtraq: NSA Group Security Advisory NSAG-?198-23.02.2006 Vulnerability The Bat v. 3.60.07
http://seclists.org/lists/bugtraq/2006/Feb/0442.html

DoS y ejecución remota de JavaScript en Thunderbird <= 1.0.7

Por marcelo-ar - 24 de Febrero, 2006, 4:54, Categoría: General

Se ha reportado una vulnerabilidad en Mozilla Thunderbird la cual podría ser explotada por atacantes remotos para ejecutar código JavaScript arbitrario.

El motor de renderizado WYSIWYG de Thunderbird no filtra completamente el codigo javascript.
Es posible escribir código javascript en el atributo SRC de una etiqueta IFRAME. Esto posibilita la ejecución de código JavaScript arbitrario cuando un mensaje de correo es editado (por ejemplo, al responderlo), aún si JavaScript está desactivado en Preferencias.
Nota: Thunderbird viene por defecto con JavaScript desactivado por razones de seguridad.

Impacto:
La explotación exitosa de esta vulnerabilidad podría permitir la revelación de información sensible u ocasionar el fallo (crash) de la aplicación.

Versiones vulnerables:
Mozilla Thunderbird 1.0.7 y anteriores

Solución:
Actualizar a Mozilla Thunderbird 1.5
http://www.mozilla.com/thunderbird/all.html

Créditos:
nono2357 at sysdream dot com
http://www.sysdream.com

Fecha de descubrimiento del fallo:
28/01/2006

Prueba de concepto:
[Ver reporte original]

Ref.:
[Full-disclosure] Mozilla Thunderbird : Remote Code Execution & Denial of Service
http://seclists.org/lists/fulldisclosure/2006/Feb/0552.html

SecurityTracker Alert ID: 1015665
Mozilla Thunderbird Validation Error in IFRAME SRC Tag Lets Remote Users Execute Arbitrary Javascript
http://securitytracker.com/alerts/2006/Feb/1015665.html

Múltiples vulnerabilidades XSS e "IMAP Injection" en SquirrelMail <= 1.4.5

Por marcelo-ar - 24 de Febrero, 2006, 4:45, Categoría: General

SquirrelMail es un popular sistema de webmail "Open Source" escrito en PHP4.

Se han identificado múltiples vulnerabilidades en SquirrelMail, las cuales podrían ser explotadas por atacantes remotos para inyectar y ejecutar comandos arbitrarios.

El primer problema es debido a un error de validación de entrada en el script "webmail.php" que no valida correctamente el parámetro "right_main", lo cual podría ser explotado por atacantes para ocasionar que código script malicioso sea ejecutado por el navegador del usuario en el contexto de seguridad del sitio afectado.

El segundo fallo es debido a un error de validación de entrada al manejar comentarios en estilos, lo cual podría ser explotado por gente maliciosa para llevar a cabo ataques XSS (cross site scripting).
La explotación exitosa de esta vulnerabilidad requiere que el usuario visualice datos maliciosos en el navegador Internet Explorer.

El tercer problema es debido a un error de validación de entrada al procesar el parámetro "sqimap_mailbox_select mailbox", lo cual podría ser explotado por atacantes para inyectar comandos IMAP arbitrarios.

Productos afectados:
SquirrelMail version 1.4.5 y anteriores

Solución:
Los parches están disponibles a través del repositorio CVS y serán incluidos en la próxima versión 1.4.6 de SquirrelMail.
http://www.squirrelmail.org/cvs

Créditos:
Vulnerabilidades reportadas por:
- El desarrollador del producto
- Scott Hughes
- Vicente Aguilera

Nota:
Para saber si su proveedor de webmail utiliza una versión vulnerable, basta con observar la página inicial de login, en la cual se suele exhibir la versión de SquirrelMail.

Ref.:
FrSIRT/ADV-2006-0689
SquirrelMail Multiple Cross Site Scripting and IMAP Injection Vulnerabilities
http://www.frsirt.com/english/advisories/2006/0689

Secunia Advisory: SA18985
SquirrelMail Cross-Site Scripting and IMAP Injection Vulnerabilities
http://secunia.com/advisories/18985/

El Blog

Calendario

<<   Febrero 2006  >>
LMMiJVSD
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28      

Categorías

Alojado en
ZoomBlog

Get Firefox!

Check Page Rank

directorio blogs
eXTReMe Tracker